libconfuse: A configuration file parser library1

Package available in: [trunk] [8.0] [7.0]

LibConfuse is a configuration file parser library written in C. It's goal is to be easy to use and quick to integrate into existing code. It supports sections and (lists of) values (strings, integers, floats, booleans, or other sections), as well as some other features (such as single/double-quoted strings, environment variable expansion, functions, and nested include statements). It makes it very easy to add configuration file capability to a program using a simple API.

... part of T2, get it here

URL: http://www.nongnu.org/confuse/

Author: Martin Hedenfalk <mhe [at] home [dot] se>
Maintainer: The T2 Project <t2 [at] t2-project [dot] org>

License: GPL
Status: Stable
Version: 2.5

Download: http://savannah.nongnu.org/download/confuse/ confuse-2.5.tar.gz

T2 source: libconfuse.cache
T2 source: libconfuse.desc

Build time (on reference hardware): 5% (relative to binutils)2

Installed size (on reference hardware): 0.02 MB, 8 files

Dependencies (build time detected): 00-dirtree bash binutils bzip2 coreutils diffutils file findutils flex gcc gettext glibc grep m4 make mktemp net-tools sed sysfiles tar util-linux

Installed files (on reference hardware): n.a.

1) This page was automatically generated from the T2 package source. Corrections, such as dead links, URL changes or typos need to be performed directly on that source.

2) Compatible with Linux From Scratch's "Standard Build Unit" (SBU).